Follow

Should I upgrade my Synergy controller's firmware? To what version?

Unless you are having specific problems related to your device's firmware and have been advised to do so by technical support, you should not need to update your firmware. Newer versions of the Synergy firmware are not always compatible with older devices and may cause interruptions of functionality when installed on unsupported devices.

That said, there will be times when an upgrade of firmware may be necessary. Use the following as guidance for what version RTB to use for the upgrade.

If your controller has a gold AMIBIOS sticker on the processor on the top circuit card (see picture), do not install an RTB that is earlier than version 3.0.

 

If your controller does not have a gold AMIBIOS sticker on the processor on the top circuit card (see picture), do not install an RTB that is greater than version 2.72.

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request